Sensei LMS FAQ

Looking for answers about Sensei LMS? This document will help.

What are the Requirements for using Sensei LMS?

As of version 2.0, you will need:

  • PHP 5.6+
  • WordPress 4.1+

If you are already running Sensei 1.x on an existing site, you will not be able to upgrade to Sensei LMS 2.0 unless your site is running PHP 5.6 or higher. has more information on how to update your site’s version of PHP.


Sensei LMS itself does not control membership, but there are two ways we have tested for creating a membership setup:

A Sensei LMS user, Richard Stibbard, has also documented another method he has used for creating a membership learning site with Sensei LMS:


Sensei LMS doesn’t interact with Articulate Storyline in any way, but there are plugins available that let you embed Articulate content into any post or lesson. This allows you to use Articulate Storyline content as the content of your lesson, and still use Sensei LMS for quizzes, grading etc. if you wish.