WordPress Core & PHP Support Policy

What Are We Doing?

As of Sensei LMS 3.4, we plan to follow WooCommerce’s lead and adopt an L-2 sliding window support policy for WordPress Core. This means that Sensei LMS will be guaranteed to work on the most recent version of WordPress, plus the latest release from the previous two versions. For example, Sensei LMS 3.4 (currently set for release on August 6th), will support WordPress 5.4.2, 5.3.4 and 5.2.7.

We will also match our minimum required version of PHP with WooCommerce, which is currently set to PHP 7.0.

Why Are We Doing This?

Sensei’s most popular extension, WooCommerce Paid Courses, requires that WooCommerce be installed in order for it to work. Because of this dependency, it follows that WooCommerce Paid Courses should use the same minimum version requirement for WordPress and PHP as WooCommerce uses. Given that Sensei LMS is also a dependency of WooCommerce Paid Courses, it too should specify the same requirement.

We hope that you’ll join us in moving forward the WordPress platform and the PHP programming language, and in helping to keep all sites running Sensei LMS up to date with the latest, greatest, and most secure software available.

Leave a Reply

Your email address will not be published. Required fields are marked *